PHP:WampServer下如何安装多个版本的PHP、mysql、apache

8/31/2015来源:PHP技巧人气:1690

php:WampServer下如何安装多个版本的PHP、MySQL、apache

作为Web开发人员,在机器上安装不同版本的php,apache和mysql有时是很有必要的。

今天,我在调试一套PHP程序的时候,该程序中使用的某些函数在低版本中无法使用,所以只能在搞个高版本的php。

以下是我成功配置后的截图  

不同版本的PHP:

不同版本的Apache:

这里我以安装php5.3.10为例进行说明

操作方法:

托盘图标左击 -> PHP -> Version -> 选择Get more...->打开网页后,就能看到以下截图:

然后,点击PHP(红色框框部分)

我这里是想安装PHP5.3.1,找到对应的版本进行下载后,就可以傻瓜换进行安装。

安装完成后,就能在wamp安装目录\bin\php\目录下发现多了个php5.3.10目录。

重启wamp,就可以在

托盘图标左击 -> PHP -> Version中切换不同的php版本了。

Apache和Mysql安装方法雷同


作者:曾是土木人(http://www.cnblogs.com/hongfei)

原文地址:http://www.cnblogs.com/hongfei/p/3582908.html